Having trouble getting Final Alone in the dark to run

Discussion about editing and mapping for Blood.
Post Reply
Legend
New user
Posts: 3
Joined: Oct 31st, 2015, 09:37

Having trouble getting Final Alone in the dark to run

Post by Legend » Oct 31st, 2015, 09:44

I got New Alone in the dark to run a while ago. Can't quite remember how though.

Using the gog version of One Unit Whole blood.

Tried copying the whole folder, adding FAITD into it and copying the db conf file, making path name adjustments etc. not having any luck though. I can get the launcher to start and run but can't actually get the game to run.

Any help is greatly appreciated.

p.s. This is what the bottom of my conf file looks like:

[autoexec]
# Lines in this section will be run at startup.

@ECHO OFF
mount C "."
imgmount D game.inst -t iso
c:
cls
BMOUSE.EXE LAUNCH FAITD.EXE -ini Blaunch.ini
exit

User avatar
Dimebog
Troll of the Opera
Posts: 2165
Joined: Aug 6th, 2006, 15:48
Contact:

Re: Having trouble getting Final Alone in the dark to run

Post by Dimebog » Nov 3rd, 2015, 22:15

"BMOUSE.EXE LAUNCH FAITD.EXE -ini Blaunch.ini "

I don't think you can just replace BLOOD.EXE with FAITD.EXE in that line. Bmouse probably doesn't work that way and you probably can't specify "-ini" for FAITD.EXE. Instead, try putting simply "FAITD.EXE" in that line or using the original line and changing Blaunch.ini with faitd.ini or whatever that is called.
Raven wrote:Nevermore.

Legend
New user
Posts: 3
Joined: Oct 31st, 2015, 09:37

Re: Having trouble getting Final Alone in the dark to run

Post by Legend » Nov 4th, 2015, 09:28

by using "BMOUSE.EXE LAUNCH blaunch.EXE -ini Blaunch.ini " with the modified blaunch.ini provided by the game files, I can get it to start, but then when I try to play a level, I get an error in the dos prompt that just says, "drive x isn't mounted". over and over.

Trying to run just faitd.exe resulted in a blue screen of death.
Last edited by Legend on Nov 5th, 2015, 08:09, edited 1 time in total.

User avatar
Dimebog
Troll of the Opera
Posts: 2165
Joined: Aug 6th, 2006, 15:48
Contact:

Re: Having trouble getting Final Alone in the dark to run

Post by Dimebog » Nov 4th, 2015, 21:36

I have no idea what faitd.exe is supposed to do, but there has to be something like "faitd.ini" which is loaded instead of blood.ini. That's how custom campaigns work. See if this ini file has any paths refering to drive X and change that to C.
Raven wrote:Nevermore.

Legend
New user
Posts: 3
Joined: Oct 31st, 2015, 09:37

Re: Having trouble getting Final Alone in the dark to run

Post by Legend » Nov 5th, 2015, 08:17

I don't know how else to explain it unless someone else has gotten it to work before. It seems to have a funky set up. I looked all over the files to find a drive x being refered to but no luck. The exact message was "drive x isn't mounted" and it repeats down the whole screen.

I found Final Alone In The Dark Here:
http://www.dukertcm.com/knowledge-base/ ... od-addons/

Edit:
tried from a fresh install and I got it to work but with a major flaw. For some reason the mouse doesn't work. I can play regular blood with the mouse no problem from the fresh install. But when trying to play the mod, it doesn't want to recognize the mouse at all.

User avatar
Dimebog
Troll of the Opera
Posts: 2165
Joined: Aug 6th, 2006, 15:48
Contact:

Re: Having trouble getting Final Alone in the dark to run

Post by Dimebog » Nov 7th, 2015, 11:33

BLOOD used to be pretty simple with a cfg file for settings and an ini file that ties a campaign together. Now things are more confusing with various dosbox .conf files, desktop shortcuts, bmouse, launchers, etc.

The main point is that you can't just swap blood.exe with fait.exe somewhere and expect things to work, especially with how convoluted things have gotten lately. Also, I'm 99% sure you can't pass "-ini" arguments to faitd.exe as if it were blood.exe. So - try going back to the basics and launching the game with faitd.ini like suggested and see where you can go from there (bmouse and other things that you feel are needed for the experience). By that, I mean something as simple as this:

blood -ini faitd.ini
Raven wrote:Nevermore.

Post Reply